Byggahus.se

Prata med IVT 490

  1. B
    Medlem Nivå 1
    Hm! Nu har jag fixat en Serie->USB-kabel, och pluggat in USB-kabeln i en USB-hub, som även har RFXtrx-en inkopplad. USB-hubben är kopplad till min Raspberry Pi på /dev/ttyUSB0. Men om jag lägger till Rego-hårdvaran på USB0 så slutar RFTtrx433 ta emot data. Jag antar att man inte kan ha två HW inkopplade på en USB-hub?

    Och om jag nu skulle vilja få detta att funka med bara Rego:n, måste jag i så fall ha någon slags mojäng mellan värmepumpen och min Raspberry?

    Det här kanske är jättedumma frågor, men jag får ta det i så fall. :)
     
  2. pacman42
    Medlem · Nivå 15
    Jo, nog skall du kunna ha två igång samtidigt, men...
    ...bägge HW försöker nog norpa tty0, eller så försöker bägge drivarna kommunicera med samma port. Kanske att rfxtrx istället hamnar på tty1. Lite uppslag fick du kanske...


    Linux är inte riktigt bra när det gäller detta. Har själv problem med att få igång Wifi på min raspberry på en hubb. Det vill sig inte riktigt, den hittar kretsen men kretsen hittar inte radion...
    ...börjar vara så pass less att jag nog drar kabel snart...
     
  3. T
    Medlem Nivå 1
    Jag tänkte försöka mig på att koppla in min IVT490 till min Raspberry Pi över USB
    Kan man ta en vanlig USB kabel och klippa itu den och plocka fram TXD, RXD, GND och VCC
    usb-till-seriell.jpeg
    så som bilden visar, ELLER behöver man en omvandlare från 5v till 3v
    Elektronik på denhär nivån är över min kunskap
    Jag vill ju absolut inte riskera att förstöra min Värmepump eller min Raspberry Pi
    För om det går att ta en USB kabel och använda den så vore det ju tämligen enkelt

    Hoppas någon sitter inne med svaret :)
    -Tobias
     
  4. pacman42
    Medlem · Nivå 15
  5. 3
    Medlem Nivå 1
    Hej pacman,

    Hittade du kontakter som passar? Jag har precis upptäckt denna tråden och ska göra precis samma sak. I mitt fall rpi 2 till ivt 490, lutar mot att jag skriver något eget för att presentera data i form av statistik och grafer. Känner inte alls igen kontakttypen på rego 400.

     
  6. T
    Medlem Nivå 1
    Jag skriver på en liten blogartikel, där jag beskriver hur jag gjort för att läsa av min IVT-490 luft-vatten värmepump.
    Om ni är intresserade så ta en kik här :
    http://www.tsoft.se/wp/2015/03/08/overvakning-av-min-ivt-490-varmepump-med-raspberry-pi/
    och här är mina diagram (som uppdateras NÄR min högst temporära plstpåseklämma sitter på plats....)
    http://tsoft.se/varmepanna/

    Ska försöka uppdatera artikeln med lite mer info som jag hittat, men i princip är det allt som behövs för att ansluta sig och få ut det så att man kan göra lite diagram.

    "My two cents"
    -Tobias
     
  7. A
    Medlem Nivå 1
    Kan man väcka liv i denna tråd? Jag har en IVT490 men hittar inte menyvalet "Dumpa data till PC" även om jag går in i I/S eller Fabriksläge.Under version står det 1.22. Någon som vet något om detta?
     
  8. pacman42
    Medlem · Nivå 15
    Den verkar rätt gammal, jag har version 2.30 och under meny 5.17 finns funktionen. Jag använder en ESP8266 för att lösa från serieporten. Nu är jag lite van, men den fick jag igång på under timmen, inklusive avkodning...
     
  9. Stark-Johan
    Medlem Nivå 2
    Vill du posta din kod? Hade varit kanon.
     
  10. pacman42
    Medlem · Nivå 15
    Visst, kan göra det ikväll.
     
  11. pacman42
    Medlem · Nivå 15
    Ursäkta, men jag glömde totalt bort detta, men nu kommer koden.

    Notera att IVT har 5V på serieporten och ESPn 3.3V, så jag har delat ned denna med tre 10kOhm motstånd, två parallella med varandra från TX på IVT och ett i serie med dessa mot GND. Mellan dem så har jag kopplat RX på ESPn (Ingen TX inkopplad på ESPn).

    Jag nyttjar bara debug-utskriften och parsar denna i min Raspberry Pi och postar därifrån in värdena i Domoticz.

     
  12. Stark-Johan
    Medlem Nivå 2
    Inga problem. Har inte haft tid att bygga något ändå.

    Tack för påminnelsen. Jag kopplar på en Wemos D1 Mini som har en 5V->3V3 regulator så jag behöver ingen voltdelare för att driva den åtminstone. Jag tänkte däremot sätta in en max3232 som jag har liggande på serieporten men det är kanske fullt tillräckligt med voltdelare på den egentligen och skippa TX på esp'n som du gjort.

    IVTn tar väl ändå inte emot några kommandon överhuvudtaget?
     
  13. pacman42
    Medlem · Nivå 15
    Det går säkert att skicka kommandon till den, men jag har inte hittat någon dokumentation om hur detta skall fungera. Gissar att det i huvudsak handlar om att man skall kunna uppdatera firmware i IVTn.

    Jag har också en NodeMCU, inte en D1-mini just på denna plats dock. Så spänningen delar inte heller jag ned. D1-kopior använder jag på många andra platser i huset, exempelvis just nu när jag jobbar med att göra min robotklippare lite smartare, en AM220AC som har debugport även den.
     
  14. Stark-Johan
    Medlem Nivå 2
    Du känner till robonect.de hoppas jag? Har fungerat fint två säsonger i min AM310.
     
  15. pacman42
    Medlem · Nivå 15
    Jo. Har harvat på många tyska forum...